package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]+\b`)
var str = `ABC ABC ABC ABc aBc abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}