$re = '/\b[A-Z]+\b/m';
$str = 'ABC ABC ABC ABc aBc abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);