package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%.*: index,`)
var str = `%arg0: index, %arg1: index,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}