$re = '/%.*: index,/m';
$str = '%arg0: index, %arg1: index,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);