using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([^:/?#]+):)?(//([^/?#]*))?([^?#]*)(\?([^#]*))?(#(.*))?";
string input = @"https://u1!""#$%&\'()*+,-./;<=>?@[\]^_`{|}~:p1!""#$%&\'()*+,-./;<=>?@[\]^_`{|}~@google.com/aaa?a=vb
https://asdasd:dasda@google.com/asdasda?a=b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}