$re = '~^(([^:/?#]+):)?(//([^/?#]*))?([^?#]*)(\?([^#]*))?(#(.*))?~m';
$str = 'https://u1!"#$%&\\\'()*+,-./;<=>?@[\\]^_`{|}~:p1!"#$%&\\\'()*+,-./;<=>?@[\\]^_`{|}~@google.com/aaa?a=vb
https://asdasd:dasda@google.com/asdasda?a=b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);