re = /([^\/api]\w*)/m
str = '/api/application/v1/method /web/application/v1/method'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end