const regex = /(\d+[x]\d+\w)([a-e])|(\d+[x]\w+)|\bS(?P<Season>\d+)E(?P<Episode>\d+)|(\b[s]\d+[e]\d+)([a-e])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+[x]\\d+\\w)([a-e])|(\\d+[x]\\w+)|\\bS(?P<Season>\\d+)E(?P<Episode>\\d+)|(\\b[s]\\d+[e]\\d+)([a-e])', 'gm')
const str = `02x01
03x02a
S03E01
s03e01a
03x02xxxxxxxxxx
s03e01xxxxxxxxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}