re = /(\d+[x]\d+\w)([a-e])|(\d+[x]\w+)|\bS(?P<Season>\d+)E(?P<Episode>\d+)|(\b[s]\d+[e]\d+)([a-e])/m
str = '02x01
03x02a
S03E01
s03e01a
03x02xxxxxxxxxx
s03e01xxxxxxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end