using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\b\d+\)\h*\K.*?(?=\b\d+\)|\z)";
string input = @"1) some text 2) some more text 3) even more text, with commas and such 4) last string that could
span multiple lines";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}