re = /(?s)\b\d+\)\h*\K.*?(?=\b\d+\)|\z)/m
str = '1) some text 2) some more text 3) even more text, with commas and such 4) last string that could
span multiple lines'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end