re = /(abcd|bcde|cdef|defg|efgh|fghi|ghij|hijk|ijkl|jklm|klmn|lmno|mnop|nopq|opqr|pqrs|qrst|rstu|stuv|tuvw|uvwx|vwxy|wxyz)+/xi
str = 'aaaa
abcd
wxyz
uvwx
rupak
axway
single characters
rupak abcd test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end