re = /(?=(?:^(?:\+?1\s*(?:[.-]\s*)?)?(?!(?:(?:.*\(.*)|(?:.*\).*)))(?:[2-9]1[02-9]|[2-9][02-8]1|[2-9][02-8][02-9]))|(?:.*\((?:[2-9]1[02-9]|[2-9][02-8]1|[2-9][02-8][02-9])\).*))(?:\+?1\s*(?:[.-]\s*)?)?(?:\(?([2-9]1[02-9]|[2-9][02-8]1|[2-9][02-8][02-9])\)?)\s*(?:[.-]\s*)?([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\s*(?:[.-]\s*)?([0-9]{4})(?:\s*(?:#|x\.?|ext\.?|extension)\s*(\d{1,15}))?$/m
str = '// valid
(555)555-5555
1 (555) 555-5555
1 (555)-555-5555
555-555-5555
+1-555-532-3455
1-555-532-3455
1-555-532-3455 ext 4
1 (555) 555-5555 extension 123456789123456
// invalid
555-5555
1234567890
555--555-5555
555-555--5555
1234567
((555))555-5555
invalidphone
+91 (123) 456-7890
123.456.7890
1 (555) 555-5555 extension 0123456789012345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end