package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:-(?:к[уа]|ре|у))+`)
var str = `-Ку-ка-ре-ку
-ка-Ку-ре
-Ку-ка-ре-ку-у`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}