$re = '/(?:-(?:к[уа]|ре|у))+/ui';
$str = '-Ку-ка-ре-ку
-ка-Ку-ре
-Ку-ка-ре-ку-у';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);