#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^)(?<!\. |\[\[(?:Category|File):[^\]\[]*)(?<!\{\||\{\{|^(?:(?:\*\s*)?'?''|\*\s*)?\[\[|<!--|^=+\s*|^#(?::|\*+)?\s*|^\*\s*(?:''')?)\b([A-Z][a-z]*)\b(?![^{}]*}}|[\w\s]*-->)(?<!\[\[(?:Category|File)(?=:[^\]\[]*]]))"
Local $sString = "* [[No Yes]]." & @CRLF & _
"" & @CRLF & _
"No Yes no Yes. No, Yes." & @CRLF & _
"== No Yes no ==" & @CRLF & _
"==== No Yes ====" & @CRLF & _
"[[No Yes]] Yes Yes no no no." & @CRLF & _
"No no [[NO Yes]]." & @CRLF & _
"'''[[No Yes]]'''" & @CRLF & _
"''[[No Yes]]'' no Yes ''[[Yes Yes]]'' no ''Yes no''." & @CRLF & _
"{{No:No|No No}}" & @CRLF & _
"* No Yes." & @CRLF & _
"* '''No Yes'''." & @CRLF & _
"* [[No Yes]]." & @CRLF & _
"* '''[[No Yes]]'''." & @CRLF & _
"# No Yes." & @CRLF & _
"#** No Yes." & @CRLF & _
"#: No Yes." & @CRLF & _
"No no no [[File:No.png|No No]] Yes [[Yes Yes]]." & @CRLF & _
"[[Category:No No]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")