const regex = /(?!^)(?<!\. |\[\[(?:Category|File):[^\]\[]*)(?<!\{\||\{\{|^(?:(?:\*\s*)?'?''|\*\s*)?\[\[|<!--|^=+\s*|^#(?::|\*+)?\s*|^\*\s*(?:''')?)\b([A-Z][a-z]*)\b(?![^{}]*}}|[\w\s]*-->)(?<!\[\[(?:Category|File)(?=:[^\]\[]*]]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(?<!\\. |\\[\\[(?:Category|File):[^\\]\\[]*)(?<!\\{\\||\\{\\{|^(?:(?:\\*\\s*)?\'?\'\'|\\*\\s*)?\\[\\[|<!--|^=+\\s*|^#(?::|\\*+)?\\s*|^\\*\\s*(?:\'\'\')?)\\b([A-Z][a-z]*)\\b(?![^{}]*}}|[\\w\\s]*-->)(?<!\\[\\[(?:Category|File)(?=:[^\\]\\[]*]]))', 'gm')
const str = `* [[No Yes]].
No Yes no Yes. No, Yes.
== No Yes no ==
==== No Yes ====
[[No Yes]] Yes Yes no no no.
No no [[NO Yes]].
'''[[No Yes]]'''
''[[No Yes]]'' no Yes ''[[Yes Yes]]'' no ''Yes no''.
{{No:No|No No}}
* No Yes.
* '''No Yes'''.
* [[No Yes]].
* '''[[No Yes]]'''.
# No Yes.
#** No Yes.
#: No Yes.
No no no [[File:No.png|No No]] Yes [[Yes Yes]].
[[Category:No No]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}