import re
regex = re.compile(r"""
(['"])(?:(?!\1|\\).|\\.)*\1
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("Hello Colm \"This is a test\\\\\\\\\"\n"
"\"This is also an NL test\"\n"
"'And this has an escaped quote don\\'t in it ' Blue Boy\n"
"\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\"\n\n"
"\"line spanning with escaped quote at the end of a line\\\"\n"
"\"\n\n"
"\"Foo Bar\" \"Another Value\" something else")
subst = "Subbed"
result = regex.sub(subst, test_str)
if result:
print(result)