#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\bDiscount\b.*)\b\d+%"
Local $sString = "Lorem ipsum dolor 10% sit amet, consectetur adipiscing elit. Morbi et " & @CRLF & _
"feugiat Discount vitae 15% urna. Sed 20% et lorem in dapibus." & @CRLF & _
"Mauris arcu dui, vestibulum eget eros eu, eleifend luctus risus."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")