use strict;
my $str = 'Lorem ipsum dolor 10% sit amet, consectetur adipiscing elit. Morbi et
feugiat Discount vitae 15% urna. Sed 20% et lorem in dapibus.
Mauris arcu dui, vestibulum eget eros eu, eleifend luctus risus.';
my $regex = qr/(?<=\bDiscount\b.*)\b\d+%/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}