import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(\\w+).*\\n?";
final String string = "• BTC ⇒ 59982.00 USD (-6.38%)\n"
+ "• ETH ⇒ 4219.78 USD (-7.94%)\n"
+ "• BNB ⇒ 581.00 USD (-8.59%)\n"
+ "• CAKE ⇒ 16.78 USD (-9.35%)\n"
+ "• BAKE ⇒ 1.880000 USD (-11.42%)\n"
+ "• GRT ⇒ 0.921331 USD (-11.18%)\n"
+ "• LINK ⇒ 29.19 USD (-10.42%)\n"
+ "• DOT ⇒ 40.76 USD (-9.92%)\n"
+ "• XRP ⇒ 1.080000 USD (-8.26%)\n"
+ "• ENJ ⇒ 2.850000 USD (-6.82%)\n"
+ "• SOL ⇒ 221.16 USD (-6.81%)\n"
+ "• DOGE ⇒ 0.236049 USD (-8.49%)\n"
+ "• PROM ⇒ 16.94 USD (-7.29%)\n"
+ "• MATIC ⇒ 1.540000 USD (-9.23%)\n"
+ "• VET ⇒ 0.146540 USD (-10.92%)\n"
+ "• ADA ⇒ 1.880000 USD (-7.45%)\n"
+ "• SHIB ⇒ 0.000049 USD (-10.75%)\n"
+ "• XTZ ⇒ 5.220000 USD (-8.97%)\n"
+ "• ONE ⇒ 0.251386 USD (-12.99%)\n"
+ "• ALGO ⇒ 1.690000 USD (-10.67%)";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}