package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^#.]*#.+\.`)
var str = `abc#.123
abc#12.3
abc#abcd.23
a#123.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}