$re = '/^[^#.]*#.+\./m';
$str = 'abc#.123
abc#12.3
abc#abcd.23
a#123.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);