package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Za-z0-9]{10}|\d+)$`)
var str = `Abc1234ten
11111
11m
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}