$re = '/^(?:[A-Za-z0-9]{10}|\d+)$/m';
$str = 'Abc1234ten
11111
11m
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);