package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\p{Bopomofo}+[ˋˇ˙]?|\p{Latin}+|\p{P}`)
var str = `ㄉㄢˋNCCㄗㄞˋ『ㄅㄠˇ ㄏㄨˋ』ㄍㄜ˙ ㄗ,ㄉㄜ˙「ㄑㄧㄢˊ ㄊㄧˊ」ㄒㄧㄚˋ。`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}