const regex = /\p{Bopomofo}+[ˋˇ˙]?|\p{Latin}+|\p{P}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\p{Bopomofo}+[ˋˇ˙]?|\\p{Latin}+|\\p{P}', 'gm')
const str = `ㄉㄢˋNCCㄗㄞˋ『ㄅㄠˇ ㄏㄨˋ』ㄍㄜ˙ ㄗ,ㄉㄜ˙「ㄑㄧㄢˊ ㄊㄧˊ」ㄒㄧㄚˋ。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}