using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\\]\\(?:[^\\]+\\)*[^\\]+)$";
string input = @" Newer 432416 2020/04/04 01:50:14 \\Steam\SteamLibrary\steam.dll";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}