$re = '/([\\\\]\\\\(?:[^\\\\]+\\\\)*[^\\\\]+)$/m';
$str = ' Newer 432416 2020/04/04 01:50:14 \\\\Steam\\SteamLibrary\\steam.dll';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);