#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?>^|\s+|\W)" & @CRLF & _
" (" & @CRLF & _
" (?>[a-z]\d*|\d+[a-z]?" & @CRLF & _
" (?>\(" & @CRLF & _
" ([a-z]\d*|\d+[a-z]?)" & @CRLF & _
" \)[a-z]?" & @CRLF & _
" )?)" & @CRLF & _
" (?>\.(?>[a-z]|\d+[a-z]?))*" & @CRLF & _
" |" & @CRLF & _
" (?>M{0,4}(?>CM|CD|D?C{0,3})(?>XC|XL|L?X{0,3})(?>IX|IV|V?I{0,3}))" & @CRLF & _
" )" & @CRLF & _
"(?>\s+|\W|$)"
Local $sString = "Appendix 1" & @CRLF & _
"6.48" & @CRLF & _
"CP 198" & @CRLF & _
"3.2.4 G" & @CRLF & _
"2" & @CRLF & _
"1." & @CRLF & _
"B." & @CRLF & _
"Appendix 1" & @CRLF & _
"Annex A" & @CRLF & _
"4A.10.1 and 4A.15" & @CRLF & _
"4A.21.10" & @CRLF & _
"Annex ii" & @CRLF & _
"A)" & @CRLF & _
"SECTION IV" & @CRLF & _
"52.19A" & @CRLF & _
"PRACTICE DIRECTION 83—" & @CRLF & _
"RSC ORDER 109" & @CRLF & _
"Rule 4" & @CRLF & _
"ADMINISTRATIVE COURT GUIDANCE" & @CRLF & _
"PRACTICE STATEMENT" & @CRLF & _
"THE PROTOCOL" & @CRLF & _
"C.6" & @CRLF & _
"Draft modules" & @CRLF & _
"CIS11:" & @CRLF & _
"Appendix 13(2)e" & @CRLF & _
"2002 no." & @CRLF & _
"(a)" & @CRLF & _
"L7.3.1.R" & @CRLF & _
"(iii)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")