import re
regex = re.compile(r"""
(?>^|\s+|\W)
(
(?>[a-z]\d*|\d+[a-z]?
(?>\(
([a-z]\d*|\d+[a-z]?)
\)[a-z]?
)?)
(?>\.(?>[a-z]|\d+[a-z]?))*
|
(?>M{0,4}(?>CM|CD|D?C{0,3})(?>XC|XL|L?X{0,3})(?>IX|IV|V?I{0,3}))
)
(?>\s+|\W|$)
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("Appendix 1\n"
"6.48\n"
"CP 198\n"
"3.2.4 G\n"
"2\n"
"1.\n"
"B.\n"
"Appendix 1\n"
"Annex A\n"
"4A.10.1 and 4A.15\n"
"4A.21.10\n"
"Annex ii\n"
"A)\n"
"SECTION IV\n"
"52.19A\n"
"PRACTICE DIRECTION 83—\n"
"RSC ORDER 109\n"
"Rule 4\n"
"ADMINISTRATIVE COURT GUIDANCE\n"
"PRACTICE STATEMENT\n"
"THE PROTOCOL\n"
"C.6\n"
"Draft modules\n"
"CIS11:\n"
"Appendix 13(2)e\n"
"2002 no.\n"
"(a)\n"
"L7.3.1.R\n"
"(iii)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")