using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http[s]?:\/\/\w+.*?\/([\w\d-_]+)\/(.*)";
string input = @"https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard
http://github.intuit.com/DEVGRU/kathiravan/scorecard";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}