re = /http[s]?:\/\/\w+.*?\/([\w\d-_]+)\/(.*)/
str = 'https://github.intuit.com/DEVGRU-kathi/kathiravan/scorecard
http://github.intuit.com/DEVGRU/kathiravan/scorecard'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end