$re = '/^(?!_|\d{3})(?!.*\.([^a-z]|.{4}))[a-z\d_.]{5,32}(?<!_)$/m';
$str = 'valide
99valide
130nevalide
val_ide
_novalide_
valide.desk
novalide....
novalide.zz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);