re = /^(?!_|\d{3})(?!.*\.([^a-z]|.{4}))[a-z\d_.]{5,32}(?<!_)$/m
str = 'valide
99valide
130nevalide
val_ide
_novalide_
valide.desk
novalide....
novalide.zz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end