package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\\]|^)[{]([^\\}]|\\(.|\n))*[}]`)
var str = `sometext {
blah \{
\}
\{
\}
}
othertext {
blah \{
\}
\{
\}
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}