re = /([^\\]|^)[{]([^\\}]|\\(.|\n))*[}]/m
str = 'sometext {
blah \\{
\\}
\\{
\\}
}
othertext {
blah \\{
\\}
\\{
\\}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end