$re = '/([w]{3})(\.*[\W]*)([\w]+)(\.*[\W]*)([\w]+)(\/)(([\w]+)([\W]+))*/m';
$str = 'https://www👑google👑com/hi-me?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);