re = /([w]{3})(\.*[\W]*)([\w]+)(\.*[\W]*)([\w]+)(\/)(([\w]+)([\W]+))*/m
str = 'https://www👑google👑com/hi-me?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end