$re = '/(.*)(?:.*\n){2}.*Contact/m';
$str = ' Invoice
CK DEF Pvt ltd Invoice Number: 14523687
Account: Karnataka Bank
Account Number: 42568965113124
Date: 03-08-2021
Company: PRENDON RICARD AUST (WINE) 705328
Email: Cherrychethan22@gmail.com
From: Australia PTY LTD
Store# Name and address of the store
3456 LX WORD SQUARE
650 gorge SP
Bangalore
573102
Contact Ph: 2 35 633 125 568
Purchase order number: 12345678
Liquor License: LIPQ274013486
Item Description UOM Qty Size Prize
258947561237 Str huge barrel 7500 ml CARTOM 1 7500 133.15
986452137954 Str HUGO Chardony 750 ml CARTOM 1 750 11.4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);