# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(?:.*\n){2}.*Contact"
test_str = (" Invoice\n\n"
"CK DEF Pvt ltd Invoice Number: 14523687\n"
" Account: Karnataka Bank\n"
" Account Number: 42568965113124\n\n"
" Date: 03-08-2021\n\n"
"Company: PRENDON RICARD AUST (WINE) 705328\n"
"Email: Cherrychethan22@gmail.com\n"
"From: Australia PTY LTD\n\n\n\n"
"Store# Name and address of the store\n\n"
"3456 LX WORD SQUARE\n"
" 650 gorge SP\n"
" Bangalore\n"
" 573102\n\n"
"Contact Ph: 2 35 633 125 568\n"
"Purchase order number: 12345678\n"
"Liquor License: LIPQ274013486\n\n"
"Item Description UOM Qty Size Prize\n"
"258947561237 Str huge barrel 7500 ml CARTOM 1 7500 133.15\n"
"986452137954 Str HUGO Chardony 750 ml CARTOM 1 750 11.4\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.