using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_)[^_]+(?=_[^_]+$)";
string input = @"12345A_FileName_FRONT_1_4
12345A_FileName_FRONT_123_424";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}