$re = '/(?<=_)[^_]+(?=_[^_]+$)/m';
$str = '12345A_FileName_FRONT_1_4
12345A_FileName_FRONT_123_424';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);