use strict;
my $str = '<br />admin-c: AFM3
<br />tech-c: AFM3
<br />billing-c: AFM3
<br />nserver: ns1.locaweb.com.br
<br />nsstat: 20190304 TIMEOUT
<br />nslastaa: 20190301
<br />nserver: ns2.locaweb.com.br
<br />nsstat: 20190304 AA
<br />nslastaa: 20190304';
my $regex = qr/<br \/>([\w-]+:{1}\s*.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}