package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<@&\!?(\d+)>$`)
var str = `<@&!302050872383242240>
<@&302050872383242240>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}