$re = '/^<@&\!?(\d+)>$/m';
$str = '<@&!302050872383242240>
<@&302050872383242240>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);