#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d{1,6}$)(?:(?:\+43|00?) ?)\d+(?:[ \/–-]\d+)*$"
Local $sString = "Allowed:" & @CRLF & _
"" & @CRLF & _
"03852 4637" & @CRLF & _
"03852 463728" & @CRLF & _
"03852/4637" & @CRLF & _
"038524637" & @CRLF & _
"03852463728" & @CRLF & _
"03852/463728" & @CRLF & _
"004338524637" & @CRLF & _
"+4338524637" & @CRLF & _
"00433852463728" & @CRLF & _
"+433852463728" & @CRLF & _
"00433852/4637" & @CRLF & _
"+4303852/4637" & @CRLF & _
"00433852/463728" & @CRLF & _
"+433852/463728" & @CRLF & _
"" & @CRLF & _
"01 23457" & @CRLF & _
"0123457" & @CRLF & _
"01/23457" & @CRLF & _
"0043123457" & @CRLF & _
"" & @CRLF & _
"+43 662 8180-0" & @CRLF & _
"0662 8180-0" & @CRLF & _
"0662 81800" & @CRLF & _
"066281800" & @CRLF & _
"0662 8180" & @CRLF & _
"06628180" & @CRLF & _
"0043662 818" & @CRLF & _
"00436628180" & @CRLF & _
"+43662 8180" & @CRLF & _
"Not Allowed:" & @CRLF & _
"" & @CRLF & _
"122" & @CRLF & _
"133" & @CRLF & _
"144" & @CRLF & _
"121" & @CRLF & _
"911" & @CRLF & _
"112" & @CRLF & _
"110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")