package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{-? ?(template|partial) \"([^() ]*)\" ?.* ?-?}}`)
var str = `{{- template "head.gohtml" -}}
{{ template "navbar.gohtml" (dict "Title" "Carson") "Site" . }}
{{ partial "toc.html" }}
{{partial "youtube.html"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}