// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){{-? ?(template|partial) \"([^() ]*)\" ?.* ?-?}}"#).unwrap();
let string = "{{- template \"head.gohtml\" -}}
{{ template \"navbar.gohtml\" (dict \"Title\" \"Carson\") \"Site\" . }}
{{ partial \"toc.html\" }}
{{partial \"youtube.html\"}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}