import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'((?:([^']*?)\\\\'[^']*?)*?)'|(?:\\\\')[^']*'([^']*)'|'([^']*?)'";
final String string = "'test' \n"
+ "more'test' \n"
+ "'test'more \n"
+ "\\'no'yes' \n"
+ "a 'one' and 'two' and 'three'... \n"
+ "nothing at all \n"
+ "'' \n"
+ "''test \n"
+ "test'' \n"
+ "te''st \n"
+ "'This is not wrong' and 'this isn\\'t either' \n"
+ "'tw\\'o repl\\'acements' in 't\\'wo stri\\'ngs'. \n"
+ "'\\\\'' \n"
+ "''' \n"
+ "'test1'\\n'test2' \n"
+ "'''' \n\n"
+ "[^\\\\]'([^']*)'|\n\n"
+ "{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\\\"2_f{BzP`.#v(yGtX\\'O+4eU[P.3&1s+ xm!\n\n\n"
+ "PMOJwnmc2s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}